Use this token to access the HTTP API:
5189255902:AAGmGbmY9EZEBgjZi7BSH7HuOsbiBRYABec
chat ID: 758341780
Pengecekan
https://api.telegram.org/bot5189255902:AAGmGbmY9EZEBgjZi7BSH7HuOsbiBRYABec/sendMessage?chat_id=758341780&text=Login $user $address" keep-result=no
Memilih SEMUA user profiles untuk di tambahkan scripts monitoring login logout user hotspot ke semua user profile.
On Login :
/tool fetch url="https://api.telegram.org/bot5189255902:AAGmGbmY9EZEBgjZi7BSH7HuOsbiBRYABec/sendMessage?chat_id=758341780&text=VOUCHER = $user , IP = $address dia LOGIN" keep-result=no
On Logout :
/tool fetch url="https://api.telegram.org/bot5189255902:AAGmGbmY9EZEBgjZi7BSH7HuOsbiBRYABec/sendMessage?chat_id=758341780&text=VOUCHER = $user , IP = $address dia LOGOUT" keep-result=no
=========================================================================
Versi 2 yang lebih lengkap yang di pakai monitoring hotspot SMKS PGRI Muara Komam
On Login :
:local mac $"mac-address";
:set mac [:ip dhcp-server lease get [:ip dhcp-server lease find mac-address="$mac"] host];
:local nama "$user";
:local ips [/ip hotspot active get [find user="$nama"] address];
:local exp [/ip hotspot user get [find name="$nama"] comment];
:local profile [/ip hotspot user get [find name="$nama"] profile];
:local datetime "$[/system clock get date] $[/system clock get time]";
:local mac [/ip hotspot active get [find user="$nama"] mac-address];
:local host [/ip dhcp-server lease get [find address="$ips"] host-name];
:local lby [/ip hotspot active get [find user="$nama"] login-by];
:local limit [/ip hotspot active get [find user="$nama"] limit-bytes-total];
:local totq [(($limit)/1048576)];
:local useraktif [/ip hotspot active print count-only];
:tool fetch url="https://api.telegram.org/bot5189255902:AAGmGbmY9EZEBgjZi7BSH7HuOsbiBRYABec/sendMessage?chat_id=758341780&text===>>USER LOGIN<<==%0A- Kode Voucher : $nama%0A- IP Address : $ips %0A- Mac Address : $mac%0A- Menggunakan : $host%0A- Metode Login : $lby%0A- Kuota : $totq Mb%0A- Expired Voucher : $exp%0A- Waktu Login : $datetime%0A- Paket : $profile%0A- User Online : $useraktif user" mode=http keep-result=no;
On Logout :
:tool fetch url="https://api.telegram.org/bot5189255902:AAGmGbmY9EZEBgjZi7BSH7HuOsbiBRYABec/sendMessage?chat_id=758341780&text=<<==USER LOGOUT==>>%0A- Kode Voucher : $user%0A- IP Address : $address" keep-result=no;
CATATAN JIKA HANYA INGIN MEMANTAU USER LOGIN MAKA ON LOGOUT NYA DI KOSONGKAN.